MozillaPL.org - polskie centrum Mozilli

Główne menu:

Thunderbird: Foldery wyszukiwania

Począwszy od wersji 0.9, Thunderbird umożliwia tworzenie folderów wyszukiwania. Folder wyszukiwania wygląda jak zwykły folder z pocztą, lecz gdy na niego klikniesz, dokonuje on wyszukiwania wedle wcześniej zdefiniowanych kryteriów i wyświetla listę wiadomości, które spełniają te kryteria. Przykładowo, możesz utworzyć folder wyszukiwania, który będzie wyświetlał wszystkie wiadomości otrzymane od danej osoby w przeciągu ostatnich 30 dni, nawet jeśli te wiadomości są przechowywane w różnych folderach i podfolderach.

Folder wyszukiwania jest folderem wirtualnym w tym sensie, że wyświetla on zbiór wiadomości, które spełniają określone kryteria wyszukiwania, podczas gdy same wiadomości pozostają tam, gdzie zostały zapisane. Jeśli zaznaczysz i usuniesz wiadomość z folderu wyszukiwania, to zostanie ona usunięta z miejsca, w którym była zapisana. Jeśli jednak usuniesz sam folder wyszukiwania, wiadomości pozostaną nienaruszone. Dodatkową rzeczą, która odróżnia folder wyszukiwania od zwykłego folderu jest to, że jeśli zmienisz jego kryteria wyszukiwania, jego wirtualna zawartość ulegnie aktualizacji. Foldery wyszukiwania pozostają w panelu folderów nawet po zamknięciu i ponownym uruchomieniu programu, i są tam tak długo, dopóki ich nie usuniesz.


Tworzenie folderu wyszukiwania

Foldery wyszukiwania tworzy się przy pomocy okienka Nowy folder wyszukiwania (ilustracja), do którego można się dostać na jeden z poniższych sposobów:

  • Z menu Edycja wybierz pozycję Znajdź -> Wyszukaj wiadomości.... Po wprowadzeniu kryteriów wyszukiwania i naciśnięciu przycisku Znajdź, możesz zapisać ustawienia poprzez kliknięcie na przycisk Zapisz jako folder wyszukiwania (ilustracja).
  • Z menu Plik wybierz pozycję Nowy -> Folder wyszukiwania...
  • Po przeprowadzeniu wyszukiwania za pomocą paska szybkiego wyszukiwania, który znajduje się nad panelem wiadomości, wybierz z rozwijanej listy pozycję Zapisz ustawienia wyszukiwania jako folder... (ilustracja).
  • Po wybraniu ustawienia z rozwijanej listy Wyświetl, znajdującej się nad panelem wiadomości, wybierz pozycję Zapisz widok jako folder... (ilustracja).

Po pojawieniu się okienka, wprowadź nazwę dla tego folderu, wybierz przy pomocy rozwijanej listy Zapisz jako podfolder miejsce, gdzie ma on zostać zapisany, a następnie dodaj lub zmodyfikuj kryteria wyszukiwania (łącznie z folderami lub podfolderami, które mają być przeszukiwane). Po zakończeniu kliknij przycisk OK, aby zamknąć okienko. Nowo utworzony folder wyszukiwania powinien teraz pojawić się w panelu folderów.

Przeszukiwanie podfolderów: jeśli chcesz utworzyć folder wyszukiwania, który będzie przeszukiwał podfoldery, to najprostszym sposobem na dokonanie tego jest skorzystanie z pierwszego ze sposobów wymienionych powyżej (Edycja -> Znajdź -> Wyszukaj wiadomości...), gdyż okienko Wyszukaj wiadomości zawiera opcję, której zaznaczenie skutkuje przeszukiwaniem podfolderów. Pozostałe trzy wymienione sposoby domyślnie przeszukują jedynie zaznaczony folder, ale nie jego podfoldery. Jeśli chcesz, aby folder wyszukiwania uwzględniał podfoldery przy wyświetlaniu wyników, kliknij na przycisk Wybierz... w okienku Nowy folder wyszukiwania i zaznacz podfoldery, które mają zostać uwzględnione.

Wyszukiwanie online kontra wyszukiwanie offline (dla folderów IMAP oraz grup dyskusyjnych)

Foldery wyszukiwania mogą przeszukiwać zawartość folderów IMAP oraz grup dyskusyjnych zarówno w trybie offline jak i online. Po prostu zgodnie ze swoimi preferencjami zaznacz lub odznacz opcję Szukaj online w okienku Nowy folder wyszukiwania.

Wyszukiwanie online jest bardziej miarodajne, gdyż zawartość folderu jest aktualizowana online przy każdorazowym otwarciu. Wadą tego rozwiązania jest jednak dłuższy czas, potrzebny na otworzenie się folderu.

Przy wyszukiwaniu offline czas otwarcia folderu wyszukiwania będzie zdecydowanie krótszy, jednak jego zawartość nie będzie odzwierciedlała zmian w nieotwieranych ostatnio przez Ciebie folderach. Przykładowo, jeśli jakieś wiadomości zostały wysłane używając konta IMAP, folder wyszukiwania pracujący w trybie offline może nie wyświetlać tych wiadomości do momentu, w którym otworzysz folder Wysłane.

Zmiana kryteriów wyszukiwania w istniejącym folderze wyszukiwania

Aby zmienić kryteria wyszukiwania w folderze wyszukiwania, który został utworzony już wcześniej, kliknij prawym przyciskiem na folderze i wybierz z podręcznego menu pozycję Właściwości... lub zaznacz folder i wybierz z menu Edycja pozycję Właściwości folderu.... Pojawi się okienko Edytuj właściwości folderu wyszukiwania. Zmień kryteria wyszukiwania wedle potrzeb, a następnie kliknij przycisk OK, aby zakończyć.

Zawartość folderu wyszukiwania nie zmieni się natychmiastowo, musisz kliknąć na jakiś inny folder, po czym ponownie kliknąć na folder wyszukiwania.

Usuwanie folderu wyszukiwania

Folder wyszukiwania możesz usunąć w taki sam sposób jak zwykły folder: poprzez kliknięcie prawym przyciskiem na folderze i wybranie z podręcznego menu pozycji Usuń folder lub poprzez menu Edycja -> Usuń folder. Jeśli w ten sposób usuniesz folder wyszukiwania, żadne wiadomości nie zostaną skasowane.

Usunięcie folderu wyszukiwania jest czynnością nieodwracalną. Nie trafi on do kosza i nie będzie mógł zostać przywrócony, jak to ma miejsce w przypadku zwykłego folderu. Pozostałe informacje

  • Na obecną chwilę nie jest możliwe przeszukiwanie folderów/podfolderów na więcej niż jednym koncie widocznym w panelu folderów.
  • Możliwe jest przenoszenie folderu wyszukiwania z jednego folderu do drugiego w obrębie tego samego konta w panelu folderów. Nie możesz jednak przenosić folderu wyszukiwania pomiędzy kontami, co dotyczy również folderów lokalnych.
  • Plik, który przechowuje dane folderów wyszukiwania nowi nazwę virtualFolders.dat i znajduje się on w Twoim profilu.

Dokument ten powstał na bazie artykułu z bazy wiedzy MozillaZine pt. Saved Search.

Tę stronę ostatnio zmodyfikowano o 11:59, 19 kwi 2007.

Osobiste:

Akcje:

:

Pomagają nam:

Przejdź do powiązanej strony

Nawigacja:

Stopka: